[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
TViXiE • View topic - Model: HDI Dune. folder.aai not correct

Model: HDI Dune. folder.aai not correct

You found a bug? Here is where you can help me track them down.

Model: HDI Dune. folder.aai not correct

Postby MrX_Cuci » Tue Jan 19, 2010 7:14 pm

The folder.aai output by tvixie is not the same as folder.png. The output tvix.aai is correct though. Changing the folder using the effects are not saved as folder.aai No realtime example is shown.
Last edited by MrX_Cuci on Wed Jan 20, 2010 2:17 pm, edited 2 times in total.
MrX_Cuci
 
Posts: 17
Joined: Fri Dec 18, 2009 6:47 pm

Share On:

Re: Model: HDI Dune. folder.aai not correct

Postby malignant » Wed Jan 20, 2010 8:15 am

I also noticed a few other "bugs" on the Dune front.

First of all Tvixie doesn't create a dune_folder.txt needed for the directory layout.
This should be easy to fix because it's the same for each folder, just a matter of adding in to the script.

Second thing i found very annoying when doing my entire movie collection last night is the way Tvixie handles icons. I'm used to High Res icons created by MyMovies, but Tvixie creates low res icons and then scales them to fit your display. Even if the icons available at lets say TMDB are very high res. This is very noticable on a 1080p display.

And the way folder icons are generated are a bit buggy. You have 2 options to select a icon, one for the folder view and another one to place in the "film stip" for the movie page layout. Why can't u use the same icon for that ?

Overall tho, i prefer this to MyMovies, i like the fanart option, the layout, but especially the simplicity in use and it is way less of a system impact then MyMovies.
Samsung LE46M86 - Denon AVR 3808A - 2x Focal 816W "Limited Edition - Focal 800CC - 2x Focal 800SR - Philips HD-DVR - Playstation 3 60 gig - Xbox360 - Wii -HTPC - Logitech Harmony 1000 - Dune BD Prime 3.0 - Qnap TS-439 3tb RAID5 NAS
malignant
 
Posts: 7
Joined: Wed Jan 20, 2010 8:09 am
Location: Netherlands

Re: Model: HDI Dune. folder.aai not correct

Postby joma » Wed Jan 20, 2010 9:38 am

joma
Development Team Leader
Development Team Leader
 
Posts: 774
Joined: Thu Aug 28, 2008 9:15 pm
Location: Sweden

Re: Model: HDI Dune. folder.aai not correct

Postby malignant » Wed Jan 20, 2010 10:09 am

I will continue tinkering again tonight when i get off work.
Thanks for the quick reply.

Looking over the post i think there is something not 100% correctly set in my dune_folder.txt
Will check this again tonight and post my results.
Samsung LE46M86 - Denon AVR 3808A - 2x Focal 816W "Limited Edition - Focal 800CC - 2x Focal 800SR - Philips HD-DVR - Playstation 3 60 gig - Xbox360 - Wii -HTPC - Logitech Harmony 1000 - Dune BD Prime 3.0 - Qnap TS-439 3tb RAID5 NAS
malignant
 
Posts: 7
Joined: Wed Jan 20, 2010 8:09 am
Location: Netherlands

Re: Model: HDI Dune. folder.aai not correct

Postby MrX_Cuci » Wed Jan 20, 2010 1:26 pm

Last edited by MrX_Cuci on Wed Jan 20, 2010 4:00 pm, edited 2 times in total.
MrX_Cuci
 
Posts: 17
Joined: Fri Dec 18, 2009 6:47 pm

Re: Model: HDI Dune. folder.aai not correct

Postby malignant » Wed Jan 20, 2010 3:45 pm

Just a quick suggestion here.

I know that the dune file explorer hides files that start with a "." like ".icon.aai".

The file pointers in the models.xml file are these just to point to the correct files or do they control the files that are being output by tvixie ?

If so it would be smart to edit them to point to the files like ".folder.aai" & ".tvix.aai"
This way the dune file browser doens't show these files, wich will clean up the "clutter" created for dir layout's while browsing your movies.
Samsung LE46M86 - Denon AVR 3808A - 2x Focal 816W "Limited Edition - Focal 800CC - 2x Focal 800SR - Philips HD-DVR - Playstation 3 60 gig - Xbox360 - Wii -HTPC - Logitech Harmony 1000 - Dune BD Prime 3.0 - Qnap TS-439 3tb RAID5 NAS
malignant
 
Posts: 7
Joined: Wed Jan 20, 2010 8:09 am
Location: Netherlands

Re: Model: HDI Dune. folder.aai not correct

Postby MrX_Cuci » Wed Jan 20, 2010 3:53 pm

If you want zero clutter use:
background_order= after_all

I posted a new version that puts a dot in front of the AAI files.
MrX_Cuci
 
Posts: 17
Joined: Fri Dec 18, 2009 6:47 pm

Re: Model: HDI Dune. folder.aai not correct

Postby malignant » Wed Jan 20, 2010 4:32 pm

It's got nothing to do with the files being generated.

The clutter i am referring to is that when you enter a directory.
I don't feel like navigating through like 6 files in alfabetical order before i reach my movie file and hit enter.

Also i don't feel like manually making a "Media_URL" link for every file.

If we were just able to hide all files in the directory wich are generated by Tvixie from the dune file browser this would leave you with your movie file already selected upon entering the directory.
So one quick hit on the play button and your movie is playing.
This way the media_url becomes an obsolete action, and the less you need to do the better :D
Samsung LE46M86 - Denon AVR 3808A - 2x Focal 816W "Limited Edition - Focal 800CC - 2x Focal 800SR - Philips HD-DVR - Playstation 3 60 gig - Xbox360 - Wii -HTPC - Logitech Harmony 1000 - Dune BD Prime 3.0 - Qnap TS-439 3tb RAID5 NAS
malignant
 
Posts: 7
Joined: Wed Jan 20, 2010 8:09 am
Location: Netherlands

Re: Model: HDI Dune. folder.aai not correct

Postby MrX_Cuci » Wed Jan 20, 2010 4:39 pm

Since the .tvixie files are generated for other models aswell I highly doubt this will ever make it into Tvixie, but who knows. It's probably easeier to get the media_url from the file / directory and output it to dune_folder.txt Same effect as your suggestion. :D
MrX_Cuci
 
Posts: 17
Joined: Fri Dec 18, 2009 6:47 pm

Re: Model: HDI Dune. folder.aai not correct

Postby malignant » Wed Jan 20, 2010 6:37 pm

First of all, icons look way way better with the new models.xml in place.

Huge thanks for that MrX_Cuci.

Second of all, went on and did some testing here.
Renamed ALL the files created with Tvixie and they are now invisible to the dune filebrowser.
Wich leaves you with the movie file selected by default.

Since this program needs additional coding when set to dune mode to generate the needed dune_folder.txt in the movie dir, it would be nice that when in "DUNE" mode all files generated start with a "."
Don't know if this is feasable but for the dune user this would be a perfect solution.

Edit : also put in a request with the dune FW dev's to let the dune expolorer see files with the extention .tvixie as system files, this hides them from the filebrowser in the dune. I think this is easier than reprogramming tivxie to add "."'s when in dune mode.

I'm off to do the rest of my movies now :)
Samsung LE46M86 - Denon AVR 3808A - 2x Focal 816W "Limited Edition - Focal 800CC - 2x Focal 800SR - Philips HD-DVR - Playstation 3 60 gig - Xbox360 - Wii -HTPC - Logitech Harmony 1000 - Dune BD Prime 3.0 - Qnap TS-439 3tb RAID5 NAS
malignant
 
Posts: 7
Joined: Wed Jan 20, 2010 8:09 am
Location: Netherlands

Next

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron